Adobe parchea una vulnerabilidad XSS en Flex SDK

Fabricantes de SoftwareMovilidadPCProyectosSeguridadSistemas OperativosWorkspace
0 0 No hay comentarios

El fallo afecta a todos los sistemas operativos (Windows, Macintosh y Linux) y expone a las aplicaciones creadas con este framework a un ataque potencial de cross-site scripting.

Adobe ha parcheado un fallo de seguridad en su kit de desarrollo de software Flex que abría la puerta a potenciales ataques de “cross-site scripting” en aquellas aplicaciones construidas con el SDK. Y, por lo tanto, al robo de datos confidenciales y el control remoto de los equipos.

Podría ser la adquisición del año, superando con creces la abosorción de McAfee por parte de Intel
El fallo afecta a Flex SDK 3.6 e inferiores, así como a 4.5.1 y superiores

Este error está presente en las versiones para Windows, Macintosh y sistemas operativos basados en Linux a partir de la numeración 3.6 e inferiores, y también en la 4.5.1 y superiores, según ha confirmado la propia Adobe. La versión más reciente del SDK es la 4.6.

Por lo tanto, se recomienda a los usuarios de Flex que “verifiquen si hay algún archivo SWF vulnerable en sus aplicaciones y los actualicen siguiendo las instrucciones y herramientas proporcionadas” por la compañía en una nota técnica.

Las opciones son o bien descargar el parche para reparar el código o centrarse en la reconstrucción de las aplicaciones y todas las bibliotecas. Las aplicaciones desarrolladas con Adobe AIR no han sido afectadas por este agujero de seguridad.

El SDK de Flex es un framework open source que permite a los desarrolladores escribir de forma sencilla apps para gran variedad de dispositivos y plataformas, y que Adobe ha ofrecido recientemente a la Fundación Apache. Puede utilizarse en combinación con multitud de herramientas para web y móvil en iOS, Android y BlackBerry.

Leer la biografía del autor  Ocultar la biografía del autor