Android, muy vulnerable

Movilidad

Una vulnerabilidad detectada en la plataforma móvil impulsada por Google ha sido señalada como peor de lo que se esperaba en primera instancia, y gracias a ella los usuarios pueden ejecutar básicamente cualquier comando con privilegios de superusuario.

Google ya está trabajando en un parche para el problema, y de hecho cualquier usuario que disponga de la compilación de Android RC29 o superior podrá estar a salvo de este defecto, que simplemente mediante la pulsación de un simple comando que por ejemplo permite resetear el teléfono desde cualquier menú o aplicación en la que se pueda introducir texto.

El problema radicaba en el fichero init.rc, y de hecho simplemente es necesario (para los que no dispongan de un software interno actualizado en los T-Mobile G1) escribir el comando “cat” para que el móvil y su sistema operativo no hagan caso del resto de palabras introducidas como si fueran comandos. De momento, y hasta que Google publique el parche de forma pública, tened cuidado si tenéis un G1.

vINQulos

ZDNet

Leer la biografía del autor  Ocultar la biografía del autor