Open webOS no será compatible con dispositivos anteriores

MovilidadSistemas OperativosWorkspace
0 0 No hay comentarios

Los desarrolladores del proyecto se centrarán en futuras piezas de hardware capaces de soportar el kernel Linux 3.3+, ya que HP no posee derechos de publicación sobre los drivers de los dispositivos ya existentes.

El sistema móvil webOS sigue su camino para convertirse en open source, pero lo hace con una noticia que probablemente decepcione a muchos de sus seguidores: no soportará dispositivos ya existentes.

Así se ha anunciado en el Open webOS Project Blog, donde se relata que el equipo de desarrollo se centrará en la compatibilidad “de futuras plataformas de hardware, donde los system-on-chips soporten el kernel Linux 3.3+ y donde las sustituciones de código abierto para componentes propietarios estén integradas”.

Esto es, que los dispositivos antiguos “no podrán ser soportados porque en ellos muchos componentes propietarios, incluidos gráficos y redes, carecen de drivers para un núcleo moderno”. O, dicho de otro modo, que a pesar de ser una versión mejorada del webOS existente en la actualidad, el lanzamiento se olvidará de dispositivos como el teléfono Pre3, la familia Pixi o la propia tableta TouchPad de Hewlett-Packard.

La razón de ser de esta decisión radica en que HP no posee derechos individuales sobre los controladores de cada uno de estos dispositivos y no puede publicar su código fuente.

Parece que aquellos usuarios que quieran actualizar sus gadgets tendrán que esperar a que algún miembro de la comunidad de código abierto se ponga manos a la obra, porque el proyecto oficial no los tendrá en cuenta. Eso sí, de momento, TouchPad podrá mantenerse con algo de vida gracias a la versión webOS Community Edition publicada a finales de junio.

Leer la biografía del autor  Ocultar la biografía del autor