Tras iOS 7 Apple ofrece “última versión compatible” de sus apps para dispositivos “antiguos”

Fabricantes de SoftwareProyectosSistemas OperativosSoftwareWorkspace

Se renueva el sistema operativo de los dispositivos móviles de la manzana mordida pero es aún muy amplio el número de usuarios que continúan utilizando iPhones, iPods y iPads de generaciones anteriores que pueden presentar problemas de compatibilidad con las versiones más modernas de algunas aplicaciones. Pensando en ellos Apple ha decidido que quienes opten por mantener en funcionamiento dichos dispositivos podrán elegir, a la hora de instalar aplicaciones, si descargar no la última versión, supuestamente optimizada para iOS 7, sino otras anteriores.

Cada dos años, de media, Apple renueva por completo sus dispositivos, algo que se está cumpliendo matemáticamente con el más popular, el iPhone.

Además de los móviles, tabletas y reproductores multimedia también evoluciona el software y puede llegar el caso, como parece estar a punto de suceder, en que la última versión del sistema operativo presente alguna incompatibilidad con los dispositivos más antiguos, algo que puede dejar “huérfanos” a los usuarios de algunas aplicaciones si sólo se ofrece la versión de la misma adaptada, en este caso, a iOS 7. De ahí que en Apple vayan a ofrecer para esos supuestos la posibilidad de descargar la última versión compatible de dichas apps, teniendo en cuenta la versión de iOS con la que cuenta el dispositivo en concreto del usuario que está tratando de instalar dicho programa.

ios ultima version compatible

Una ventana emergente aparece en la pantalla del dispositivo avisando de que al no detectarse la versión más avanzada instalada en el dispositivo se sugiere en su lugar instalar una versión anterior de dicha aplicación, tras haber analizado qué versión es la que tiene instalada dicho dispositivo. Algunos usuarios han comenzado a ver estos mensajes que parecen anteceder la puesta a disposición de los usuarios de iOS 7 prevista para este miércoles, permitiendo también a muchos usuarios que quizá no sean partidarios del peculiar diseño del nuevo sistema operativo de Apple mantener las versiones anteriores sin demasiados problemas.

Esto permitirá que, por ejemplo, se pueda instalar Instagram en un iPhone 3GS con iOS 4.3.3 o incluso Twitter en un iPhone 3G, lo que hasta ahora no se podía conseguir por los mencionados problemas de retrocompatibilidad.

vINQulo

Reddit

Leer la biografía del autor  Ocultar la biografía del autor